Choose your color scheme:
The Vette Barn  
 
Go Back   The Vette Barn > C4 Corvette > C4 Open Discussion

C4 Open Discussion General and technical C4 Corvette discussion - ownership, maintenance, repairs, modifications, tuning

User Tag List

Reply
 
Share Thread Tools
Old 09-07-2015, 02:17pm   #1
quadracerx
Vette Barn nOOb
Points: 2,283, Level: 30
Activity: 1.2%
 
quadracerx's Avatar
 
Join Date: Jul 2015
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Gameroom Barn Bucks: $700
Default IAC valves...

Now the car runs good EXCEPT it idles VERY high... I have done the following:

Replaced both TBI Base Gaskets again.
Checked for vacuum leaks
Rechecked vacuum hose connections and routing

I THINK it could be either:

Bad IAC Valve or valves
Bad Temp Sensor

Unless you guys have other ideas?

Next question:

My lower radiator hose is never hot? I have run the car for 20 or so minutes but the lower hose doesn't really get hot...

I have a new:

radiator
new upper and lower hoses
new heater control valve
new heater hoses
new thermostat
new radiator cap

I am going to try to disconnect the upper hose and pour some antifreeze down it to try and get proper flow. The upper hose gets to about 220 degrees using a inferred temp gun.

I realize that the top of the radiator is below the level of the thermostat so the odds of a vapor/air bubble is probable...

Any other ideas?

Thanks so much for all your help...

I feel like Im almost there!!

Steve
quadracerx is offline   Reply With Quote
Old 09-09-2015, 07:02pm   #2
SQUIRMIN VERMIN 84
Barn Stall Owner #49
Points: 16,816, Level: 89
Activity: 13.4%
 
SQUIRMIN VERMIN 84's Avatar
 
Join Date: Jan 2011
Location: People's Kollektive of Seattle
Posts: 17,576
Thanks: 13,162
Thanked 3,086 Times in 1,674 Posts
Gameroom Barn Bucks: $1023337
Default

How many inches of manifold vacuum are you pulling?
SQUIRMIN VERMIN 84 is offline   Reply With Quote
Old 09-09-2015, 09:15pm   #3
quadracerx
Vette Barn nOOb
Points: 2,283, Level: 30
Activity: 1.2%
 
quadracerx's Avatar
 
Join Date: Jul 2015
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Gameroom Barn Bucks: $700
Default

Well, now I have everything hooked up except the AC Clutch Switch... And I have a situation where there is steam coming from the exhaust manifold area on the passenger side and smoke (clear or white) coming from the exhaust....

I think I have a blown head gasket or cracked head!!

I feel like I want to give up!!

One of my friends suggested I pressure check the cooling system and see if I could get it to lose coolant from the passenger side?

And if nothing else try some KW Block Seal and see if that fixes it...?

Ive spent so much time and money on this thing, I just want to be able to enjoy it for a while... Ill eventually rebuild the motor and trans... But Im out of money now until next summer...

Any thoughts would be appreciated...

Steve
quadracerx is offline   Reply With Quote
Old 09-09-2015, 09:16pm   #4
quadracerx
Vette Barn nOOb
Points: 2,283, Level: 30
Activity: 1.2%
 
quadracerx's Avatar
 
Join Date: Jul 2015
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Gameroom Barn Bucks: $700
Default

As for the vacuum signal... Ill check it the next time I start it next week....

Thanks for your help...

Steve
quadracerx is offline   Reply With Quote
Old 09-25-2015, 05:35am   #5
hcbph
Vette Barn nOOb
Points: 3,525, Level: 39
Activity: 0%
 
hcbph's Avatar
 
Join Date: Aug 2013
Location: Minnesota
Posts: 16
Thanks: 1
Thanked 12 Times in 8 Posts
Gameroom Barn Bucks: $575
Default

If you have an airlock, here's something I've done in the past that has worked on a couple of cars. Find a parking ramp with as high an incline as you can get. With the engine hot, turn the heater controls to high, put it in low and go up the inclines as fast as safely as you can. I did it off hours when there was no traffic and went up and down several times and at the end the air had pushed through to the radiator.

Good luck.
hcbph is offline   Reply With Quote
Reply

The Vette Barn > C4 Corvette > C4 Open Discussion


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:12am.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright 2009 - 2019 The Vette Barn


Support the Barn:
 
Download the Mobile App;
 
Follow us on Facebook:

Become a Stall Owner

 

Apple iOS App        Google Android App

 

Visit our Facebook page