Choose your color scheme:
The Vette Barn - A Community for Corvette Lovers  
Go Back   The Vette Barn - A Community for Corvette Lovers > C4 Corvette > C4 Open Discussion

C4 Open Discussion General and technical C4 Corvette discussion - ownership, maintenance, repairs, modifications, tuning

User Tag List

Share LinkBack Thread Tools
Old 09-25-2017, 11:20am   #1 (permalink)
Vette Barn nOOb
Points: 46, Level: 1
Activity: 1.3%
Magnet925's Avatar
Join Date: Sep 2017
Posts: 3
Thanks: 1
Thanked 0 Times in 0 Posts
Gameroom Barn Bucks: $515
Default FX3 ride control

Just bought a 1993 C4. On start the Service Ride Control light DOES NOT come on. The ride control switch makes no difference in ride and it is a very hard ride. We have inspected the Bilstein Shocks appear to be good no leaks but very firm pushing down on frame. I have checked the ride control module behind the seat and nothing is disconnected. any thoughts or help would be appreciated.

Last edited by Magnet925; 09-26-2017 at 10:04am. Reason: Title change
Magnet925 is offline   Reply With Quote

The Vette Barn - A Community for Corvette Lovers > C4 Corvette > C4 Open Discussion

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 12:01pm.

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
ShowCase vBulletin Plugins by Drive Thru Online, Inc.

Search Engine Friendly URLs by vBSEO 3.6.0 RC 1
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright 2009 - 2018 The Vette Barn

Support the Barn:
Download the Mobile App;
Follow us on Facebook

Become a Stall Owner


Apple iOS App        Google Android App


Visit our Facebook page