Choose your color scheme:
The Vette Barn - A Community for Corvette Lovers  
 
Go Back   The Vette Barn - A Community for Corvette Lovers > C4 Corvette > C4 Open Discussion

C4 Open Discussion General and technical C4 Corvette discussion - ownership, maintenance, repairs, modifications, tuning

User Tag List

Reply
 
Share LinkBack Thread Tools
Old 02-28-2017, 11:16pm   #1 (permalink)
Vette Barn nOOb
Points: 20, Level: 1
Activity: 0.8%
 
bubb21396's Avatar
 
Join Date: Feb 2017
Posts: 2
Thanks: 1
Thanked 0 Times in 0 Posts
Gameroom Barn Bucks: $510
Default 1984 corvette

hi friends i have a 1984 vette that wont run after it gets hot. I figured i had a bad ignition control module so i replaced that but after about a half hour it runs rough and if u shut it off it wont start. My next guess was a clogged fuel filter so i changed that today, after i put the new fuel filter on car wont start at all now. Any advice thank you
bubb21396 is offline   Reply With Quote
Reply

The Vette Barn - A Community for Corvette Lovers > C4 Corvette > C4 Open Discussion


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 08:00pm.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
ShowCase vBulletin Plugins by Drive Thru Online, Inc.

Search Engine Friendly URLs by vBSEO 3.6.0 RC 1
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright 2009 - 2017 The Vette Barn


Support the Barn:
 
Download the Mobile App;
 
Follow us on Facebook

Become a Stall Owner

 

Apple iOS App        Google Android App

 

Visit our Facebook page